В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
den6580
den6580
08.12.2021 21:41 •  Информатика

Напишите программу,которая последовательности натуральных чисел определяет сумму нечётных двухзначных чисел.программа получает на вход кол-во чисел в прследовательности, а затем сами числа.кол-во чисел не превышает 1000.введенные числа не превышают 30 000.программа должна вести одно число-сумму нечетных двухзначных чисел в данной последовательности

Ответ:
Ангелина22325
Ангелина22325
01.09.2020 06:16
Program hhh54;
var i,n,x,s:longint;
begin
  s:=0;
  read (n);
  for i:= 1 to n do
    begin
      read (x);
      if (x > 9) and (x < 100) and (x mod 2 <> 0) then s:=s+x; 
    end;
  write (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?