В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу, которая вычисляет сумму натуральных чисел, кратных 7, в диапазоне от a до b (a и b - введены с клавиатуры).

Ответ:
elsoc
elsoc
06.10.2020 10:26
Program a1;
uses crt;
var
ta,b, i,s:integer;
begin.
readln(a);
readln(b);
s:=0;
if a > b then
for i:= a to b do
if i mod 7 = 0 then
s:=s+i;
else
else
if b > a then
for i:= b to a do
if i mod 7 = 0 then
s:=s+i
begin
end;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?