В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
karolina85
karolina85
18.01.2023 00:50 •  Информатика

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного n. простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число

Ответ:
gerasim4uckirip08lfr
gerasim4uckirip08lfr
06.10.2020 09:52
#Python 3.5.2
a = []
n = int(input('Введите n: '))
for i in range (n+1): a.append(0);
for i in range (2, n+1):
    if a[i]==0:
        print (i, end='; ')
        j = 2*i
        while j<=n:
            a[j] = 1
            j+=i
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?