В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kulagindemid20
kulagindemid20
24.07.2020 18:43 •  Информатика

Напишите программу, которая находит квадрат произведения цифр введенного числа

Ответ:
Vikadianalol
Vikadianalol
06.10.2020 09:16
Var a,p:integer;
begin
write('a = ');
readln(a);
a:=abs(a);
p:=1;
while a<>0 do
 begin
 p:=p*(a mod 10);
 a:=a div 10;
 end;
p:=p*p;
writeln('p = ',p);
end.

Пример:
a = 273
p = 1764
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?