Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sgymgjvb
10.03.2021 17:36 •
Информатика
25б. напишите, , программу(паскаль).условие: ввести n любых чисел. вычислить p,s,k и выдать на экран (p-произведение отрицательных чисел, s-сумма положительных чис., k-количество отрицат. чисел)
Ответ:
batyka228
06.10.2020 09:08
Var
N,K,A:integer;
S,P:real;
Begin
Write('N = ');ReadLn(N);
K:=0;
P:=1;
For N:= 1 to N do
Begin
Read(A);
if A < 0 then
Begin
P:=P*A;
K:=K+1
End
else if A > 0 then S:=S+A;
End;
WriteLn('S = ',S);
WriteLn('P = ',P);
WriteLn('K = ',K);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
esya14
16.05.2022 22:02
Выставила 20 , надеюсь, этого и правда будет достаточно! определите, что будет напечатано в результате работы следующей программы. построить трассировочную таблицу(фото)...
KseniaRogalina
04.04.2021 04:18
Ниже приведены за к поисковому серверу. Изобразите графически количество страниц, отображаемых по каждому из за в отдельности. Проанализируйте графические изображения...
skawin2017
28.04.2020 01:16
Составить программу для нахождения корней квадратного уравнения ах2+вх+с...
57601
28.04.2020 01:16
1.напишите алфавит для системы счисления с основанием 20. 2.получить развернутую форму десятичного числа 32478,38....
romanvailev15
28.04.2020 01:16
Чему в десятичной системе равны следующие двоичные числа 1000001 10000001...
DarknEssDk11
07.03.2020 14:49
Заполните пропуски числами: =__байт= 8192 бит гбайт =1536 мбайт=__кбайт...
12323543654
07.03.2020 14:49
Перевод с языка на язык можно назвать информационным працессом?...
ErikLusenko
07.03.2020 14:49
Алгоритмика. 1) придумать и представить в виде блок-схемы линейный алгоритм....
yuri520
25.05.2020 04:06
Использованием информации может быть: а)крик о б)речь диктора в)обучение в школе г)свет далекой звезды д)звон колокола...
marvin4547
22.09.2022 16:08
Вдва супермаркета 3 тонны картофеля какую было распаковано в одинаковые сетки в первом супермаркет перевезли 530 сеток картофеля а в втором 470 сеток сколько килограмм...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
N,K,A:integer;
S,P:real;
Begin
Write('N = ');ReadLn(N);
K:=0;
P:=1;
For N:= 1 to N do
Begin
Read(A);
if A < 0 then
Begin
P:=P*A;
K:=K+1
End
else if A > 0 then S:=S+A;
End;
WriteLn('S = ',S);
WriteLn('P = ',P);
WriteLn('K = ',K);
End.