В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Super364
Super364
01.07.2020 19:32 •  Информатика

Информатика (pascal): составить программу для решения следующей : среди всех положительных трёхзначных чисел найти и выписать на экран те,у которых сумма крайних цифр совпадает с утроенной средней цифрой.

Ответ:
karas14
karas14
06.10.2020 09:02
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  for var i:=1 to 9 do
    for var j:=0 to 9 do
      for var k:=0 to 9 do
        if i+k=3*j then Write(i,j,k,' ');
  Writeln
end.

Результат
112 125 138 211 224 237 310 323 336 349 422 435 448 521 534 547 620 633 646 659 732 745 758 831 844 857 930 943 956 969
0,0(0 оценок)
Ответ:
23redalice11
23redalice11
06.10.2020 09:02
Var a,b,c:byte;
Begin
For a:= 1 to 9 do
    For b:= 0 to 9 do
        For c:= 0 to 9 do
            if a+c = 3*b then Write(a,b,c,' ')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?