В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lerkacom2
lerkacom2
23.07.2022 10:26 •  Информатика

Напишите программу в pascal abc, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 5 или 9. входные данные: 15 91 90 0 выходные данные: 2

Ответ:
Дарина37373
Дарина37373
06.10.2020 08:26
Var a,k:integer;
begin
k:=0;
readln(a);
while a<>0 do
 begin
 if (abs(a) mod 5=0)or(abs(a) mod 9=0)
  then k:=k+1;
 readln(a);
 end;
writeln('k = ',k);
end.

Пример:
15
91
90
0
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?