В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zhienalinaadel
zhienalinaadel
02.01.2021 06:39 •  Информатика

На языке программирования паскаль напишите программу, которая: 1) в последовательности чисел находит количество чисел, кратных 3. 2) в последовательности чисел находит максимальное четное число, оканчивающееся на 4.

Ответ:
dasha1933
dasha1933
03.08.2020 12:47
1)
program kr3sum;
var i,s.h:integer;
begin 
read(k) //кол чисел 
for i:=1 to k do begin 
read(h) //число для действий 
if h mod 3 = 0 then begin s:=s+1;
end;
writeln(s);
end.
2)
program jeje; 
var k,i,m,s,h:integer;
begin m:=0;
read(k);//кол-во чисел
for i:=1 to k do begin
readln(h);
if h mod 10 = 4 then begin s:=h;
            if s > m then m:=s                       
   end;
end;
write(m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?