В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Loikov1
Loikov1
10.11.2022 14:40 •  Информатика

Написать программу: подсчитать сумму двузначных четных чисел в диапазоне заданном пользователем. используя оператор !

Ответ:
RaiderUp
RaiderUp
06.10.2020 06:15
Для наглядности и простоты проверки оставил вывод слагаемых:

Var S,a,b:integer;
Begin
WriteLn('Сумма нечётных двузначных чисел в [a,b]');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
S:=0;
if a mod 2 = 0 then a:=a+1;
if a < -10 then
   Begin
   if a < -99 then a:=-99;
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>-11)or(a>b);
   a:=11;
   End;
if (b>10)and(a<100) then
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>99)or(a>b);
WriteLn('S = ',S)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?