В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ArsenKk
ArsenKk
17.05.2023 00:13 •  Информатика

Составить программу для решения следующей : приближенно можно считать, что скорость охлаждения горячего чая, налитого в стакан, пропорциональна разности между его температурой и температурой воздуха. за 1 минуту температура чая снижается на 3 % от разности этих температур. вывести на экран температуру чая по истечении каждой минуты в течении 15 минут. начальная температура воздуха - 20 градусов, начальная температура чая - 100. протокол: через 0 мин. - 100 градусов через 1 мин. - 97,6 градусов через 2 мин. - 95,3 градусов через 3 мин. - 93,1 градусов …

Ответ:
123QWE123QWE12345678
123QWE123QWE12345678
03.08.2020 12:22
Считаем, что изменением температуры воздуха можно пренебречь:
var t,t1:real; i:integer;
begin
t:=100;
t1:=20;
for i:=0 to 15 do
 begin
 writeln('Через ',i,' мин. - ',t:4:1,' градусов');
 t:=t-(t-t1)*0.03;
 end;
end.

Результат:
Через 0 мин. - 100.0 градусов
Через 1 мин. - 97.6 градусов
Через 2 мин. - 95.3 градусов
...
Через 14 мин. - 72.2 градусов
Через 15 мин. - 70.7 градусов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?