Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
shadow909
18.01.2022 02:11 •
Информатика
Дано целое положительное трехзначное число n. составить программу ,которая определяет входит ли в него цифра 8.
Ответ:
ykim1337
06.10.2020 05:19
Var n:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(n);
n:=Abs(n);
if (n div 100 = 8)or((n div 10) mod 10 = 8)or(n mod 10 = 8) then WriteLn('Входит')
else WriteLn('Не входит')
End.
Пример работы программы:
Введите трёхзначное число: 85
Входит
0,0
(0 оценок)
Популярные вопросы: Информатика
sveta2015w
13.11.2021 22:02
1)Что лежит в основе моделирования? 2)Приведите примеры моделей в реальной жизни.3)Какую роль сыграли компьютеры в развитии процессов моделирования?4)Поясните суть модуляции и...
Ларейн2772
13.07.2021 09:19
Создайте программу последуещему сценарию: у пользователя запрашивается длина стороны. на холсте случайным цветом рисуется пятнадцать-угольник с заданной длинной стороны и заливается...
dimon2512
30.07.2022 10:43
Что такое префикс сети (network prefix)? а .первый октет IP-адреса б.шестнадцатеричное число, равное числу разрядов маски подсети, установленных в единицу с .десятичное число,...
зынзын
31.07.2022 11:49
Диофантово уравнение Даны натуральные числа a, b, c. Если уравнение ax+by=c имеет решения в целых числах, то выберите то решение, в котором число x имеет наименьшее неотрицательное...
baburina56vValiabab
09.03.2020 01:01
Какое десятичное число является эквивалентом двоичного числа 11111111? 16 64 256 255...
VladusGrif
18.05.2023 16:42
какой из них не является видом информации текстовая информация графическая информация пиксельная информация...
Velichkovskaya0
20.10.2020 11:33
Как называется основная программа?...
Чаромаг
20.01.2022 16:26
сколько всего информационных процессов вы знаете а) 2 в) 3 с) 5...
olesmekhedova
27.03.2022 20:15
каких из этих устройств обрабатывает информацию а)клавиатура в)процессор с)долговременная память...
Эллада20029
02.07.2020 13:04
Вопросы к словам графика, растр, сканер, формат, пиксель, вектор...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Begin
Write('Введите трёхзначное число: ');ReadLn(n);
n:=Abs(n);
if (n div 100 = 8)or((n div 10) mod 10 = 8)or(n mod 10 = 8) then WriteLn('Входит')
else WriteLn('Не входит')
End.
Пример работы программы:
Введите трёхзначное число: 85
Входит