В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
artemcxt
artemcxt
13.11.2022 22:02 •  Информатика

Написать программу которая вводит с клавиатуры одномерный массив из 10 целых чисел после чего выводит количество ненулевых элементов. перед вводом каждого элемента должна выводиться подсказка с номером элемента !

Ответ:
Noyaneya
Noyaneya
06.10.2020 05:15
Const n=10;
var a: array[1..n] of integer;
k,i: integer;
begin
k:=0;
for i:=1 to n do
begin
writeln('элемент', i);
readln(a[i]);
if a[i] <> 0 then k:=k+1
end;
writeln(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?