В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на языке программирования паскаль 1)зная температуру воздуха ,определить вид осадков (дождь или снег) 2)найдите сумму цифр заданного трехзначного числа 3)если первое число больше второго ,то определить квадрат меньшего числа ,а в противном случае - произведение чисел

Ответ:
ivanignatov201
ivanignatov201
06.10.2020 04:56
Var
   t:integer;
Begin
Write('Введите температуру воздуха: ');ReadLn(t);
if t > 0 then Write('Дождь')
else Write('Снег')
End.

Var
   A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
A:=Abs(A);
WriteLn(A div 100,'+',(A div 10) mod 10,'+',A mod 10,' = ',A div 100+(A div 10) mod 10+A mod 10);
End.

Var
   A,B:integer;
Begin
Write('Введите два числа: ');ReadLn(A,B);
if A>B then Write('Квадрат меньшего: ',B*B)
else Write('Произведение чисел: ',A*B)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?