В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
e12esa
e12esa
20.10.2020 12:41 •  Информатика

Определить, сколько раз в тексте встречается заданное слово. написать программу, паскаль

Ответ:
uIia454
uIia454
06.10.2020 04:30
Var
  s, sl, sc: string;   
  i, k: integer;

begin
  write('Введите текст ');
  readln(s);
  write('Введите слово ');
  readln(sl);
  s:=' '+s+' ';
  sl:=' '+sl+' ';
  for i := 1 to length(s) - length(sl) + 1 do   
  begin
    sc := copy(s, i, length(sl));   
    if sc = sl then inc(k);   
  end;
  if k = 0 then writeln('Не встречается')  
  else writeln('Встречается ', k, ' раз');
end.
0,0(0 оценок)
Ответ:
VikaBakevich
VikaBakevich
06.10.2020 04:30
Var
   k,i,L:integer;
   S,C:string;
Begin
Write('Введите текст: ');ReadLn(S);
Write('Введите искомое слово: ');ReadLn(C);
L:=Length(C);
S:=Copy(C,1,L-1)+' '+S+' ';
S:=LowerCase(S);
C:=LowerCase(C);
k:=0;
For i:= 1 to Length(S) do
    if S[i]in['а'..'я','А'..'Я','ё','Ё','0'..'9'] then
       if S[i+1]in[' ','-','(',')',',',';',':','.','!','?'] then
          if Copy(S,i-L+1,L) = C then k:=k+1;
WriteLn(k);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?