В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Николо223
Николо223
31.07.2021 03:55 •  Информатика

Написать программу в паскаль. сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2

Ответ:
marina999mmm
marina999mmm
06.10.2020 04:22
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(' ',A[i]);
    if A[i] < 0 then
       Begin
       k:=k+1;
       A[i]:=2
       End;
    End;
WriteLn;
WriteLn('Количество отрицательных элементов: ',k);
Write('Новый массив:');
For i:= 1 to N do
    Write(' ',A[i])
End.

Пример работы программы:

Исходный массив: -1 -9 7 -2 -5 -3 -1 6 3 -6 9 8 -10
Количество отрицательных элементов: 8
Новый массив: 2 2 7 2 2 2 2 6 3 2 9 8 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?