В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
09213
09213
29.03.2020 01:16 •  Информатика

Составьте программу вычисления суммы повторяющихся элементов одномерного массива. (паскаль)

Ответ:
Kvintsekstakkord
Kvintsekstakkord
26.08.2020 12:09
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Writeln('Sдубл=',a.GroupBy(c->c).Select(c->(c.Key,c.Count))
      .Where(c->c[1]>1).Select(c->c[0]*c[1]).Sum)
end.

Пример
n= 15
1 2 -10 18 8 -18 -8 -6 -11 -7 -10 -11 3 2 2
Sдубл=-36
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?