В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vajsn
vajsn
30.01.2020 04:48 •  Информатика

Нужно написать программу на языке с++: дана последовательность целых чисел, за которой следует 0. найти разность минимального и максимального элементов в этой последовательности.

Ответ:
Tatuhenka3
Tatuhenka3
06.10.2020 03:35
#include<iostream>
using namespace std;
int main()
{
    int A;
    cin >> A;
    int Min = A;
    int Max = A;
    while(A)
    {
        cin >> A;
        if (Max < A && A!=0) Max = A;
        if (Min > A && A!=0) Min = A;
    }
    cout <<"Min = "<<Min<<"\n";
    cout <<"Max = "<<Max<<"\n";
    cout <<"Min - Max = "<<Min-Max<<"\n";
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?