В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ctalin123123
ctalin123123
17.12.2020 19:17 •  Информатика

Напишите программу (паскаль) для вычисления разности s=1 - 1*2 - 1*2*5 - 1*2*5*8 - 1*2*5*8*11

Ответ:
джемре
джемре
06.10.2020 03:29
Первый вариант:

Var
   A,N:longint;
   S,P:real;
Begin
Write('Введите количество членов последовательности(не менее одного): ');
ReadLn(N);
S:=1;
P:=1;
For N:= 0 to N-1 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.

Второй вариант:

Var
   A,N:longint;
   S,P:real;
Begin
S:=1;
P:=1;
For N:= 0 to 3 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?