В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
annakokesnik
annakokesnik
20.08.2022 20:18 •  Информатика

Дан массив a(n). определите количество четных элементов с четными индексами, кратных 7. выведите на экран исходный массив и полученное количество.

Ответ:
Rımma7
Rımma7
06.10.2020 03:03
Const n=10; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if (a[i] mod 2=0)and(a[i] mod 7=0)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
25 29 13 39 9 14 27 16 12 45
k = 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?