В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Hapec
Hapec
02.02.2020 21:11 •  Информатика

Напишите программу, которая в последоательности натуральных чисел оределяет сумму всех чисел, кратных 6 и оканчивающтхся на 2. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел кратных 6 и оканчивающихся на 2. вводные данные 12, 24, 22, 72, 11, 0. выходные данные 84 !

Ответ:
sonyaflayps29
sonyaflayps29
26.08.2020 11:57
Var A:byte;
    S:integer;
Begin
Repeat
Read(A);
if (A mod 6 = 0)and(A mod 10 = 2) then S:=S+A;
Until A = 0;
Write(S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?