В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0773
0773
02.04.2020 12:05 •  Информатика

дан массив из 20 элементов.найти кол-во элементов оканчивающихся на 4. программа паскаль. написать программу

Ответ:
камила20053
камила20053
20.08.2020 17:55
Var i, k: integer;
var arr: array[0..19] of integer;

begin 
  for i := 0 to 19 do   
    read(arr[i]);  
  for i := 0 to 19 do 
    if arr[i] mod 10 = 4 then     
      k := k + 1;       
  writeln(k);
end.
0,0(0 оценок)
Ответ:
ehidna666
ehidna666
20.08.2020 17:55
Const
   N = 20;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(201)-100;
    Write(A[i],' ');
    if Abs(A[i]) mod 10 = 4 then k:=k+1
    End;
WriteLn;
WriteLn('k = ',k);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?