В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ЛебедЪ
ЛебедЪ
11.05.2022 01:19 •  Информатика

Написать программу в паскале в массиве а (15) целых чисел поменять местами 5 и 13 элементы. вывести начальный и изменены массивы в строку через два пробела.

Ответ:
dimadementev2
dimadementev2
06.10.2020 02:21
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(15,-50,50); a.Println('  ');
  Swap(a[4],a[12]); // индексы от нуля
  a.Println('  ')
end.

Пример
40  28  18  1  35  -50  13  17  40  7  -48  46  -12  -9  50
40  28  18  1  -12  -50  13  17  40  7  -48  46  35  -9  50
0,0(0 оценок)
Ответ:
kurzaevaelenka
kurzaevaelenka
06.10.2020 02:21
program fff;
const
  n = 15;
var
  arr: array[1..n] of integer;
  t : integer;
begin
  for t := 1 to n do begin
    arr[t] := random(101);
    write(arr[t], '  ');
  end;
  writeln();
  t := arr[5];
  arr[5] := arr[13];
  arr[13] := t;
  for t := 1 to n do begin
    write(arr[t], '  ');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?