Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lady198026
15.11.2022 12:24 •
Информатика
Программа на языке паскаль. ввести с клавиатуры целое число, если оно положительное возвести его в квадрат, если отрицательное возвести в четвёртую степень. напечатать результат на экране
Ответ:
MashaTears1
06.10.2020 02:08
Program rezultat;
var a: integer;
begin
write('a='); readln(a)
if a>0 then write(sqr(a))
else write(sqr(a)*sqr(a))
end.
sqr(a) - квадрат числа
0,0
(0 оценок)
Популярные вопросы: Информатика
ВЕSТ
22.02.2023 21:08
РЕБЯТА ПАСКАЛЬ УЖЕ НАДО ОТПРАВИТЬ...
milkovvich
25.10.2020 20:11
№1 требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и ь хотя бы одно четное. была написана следующая...
Ahha118
02.09.2020 19:05
1) Для чево нужен суперкомпьютер Ломоносов если есть обычные компьютеры? 2)Как связан суперкомпьютер Ломоносов с Ломоносовым?...
katyasergienko2004
31.07.2022 20:45
Инструментами в графическом редакторе являются… * Линия, круг, прямоугольниктекст, шрифт, абзацКарандаш, кисть, ластикВыделение, копирование хэлп ...
hiset37281
29.04.2022 02:58
CD объемом 700 МБайт весит 20г. Сколько будет весить набор таких дисков , необходимый для полного копирования информа ции с жёсткого диска объемом 340 Гбайт ?...
Angela280
19.04.2022 07:43
Перечислите основные законодательные акты...
kjhgfffdpavel
02.12.2022 10:22
Даны два действительных числа а и б. получить их сумму, разность и произведение. написать программу так, чтобы результат выводился полным ответом (например, 4*5=20, если...
masha0301
02.12.2022 10:22
Вычислить периметр треугольника, стороны которого равны 4,5 и 7 см.записать это все в паскаль...
mmmm50
10.12.2021 08:08
Ввести число, обозначающее количество секунд. вывести то же самое время в часах, минутах и секундах. пример: число секунд: 8325 2 ч. 18 мин. 45 с нужно чтобы программа была...
maximunicorn1
29.09.2021 17:52
Какая программа автоматизирует процессы построения графических изображений на экране компьютера...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a: integer;
begin
write('a='); readln(a)
if a>0 then write(sqr(a))
else write(sqr(a)*sqr(a))
end.
sqr(a) - квадрат числа