В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
khvvt1
khvvt1
06.01.2022 14:27 •  Информатика

Напишите программу, которая сортирует массив по убыванию и ищет в нем все значения, равные введенному числу. pascalabc

Ответ:
cstlm
cstlm
31.08.2020 23:22
Const n=20; 
var
  a:array[1..n] of integer;
  i,j,t,x,i1,i2:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(21);
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]<a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln;
 write('x = '); readln(x);
 i1:=1; i2:=n;
 repeat
  i:=(i1+i2) div 2;
  if a[i]>x then i1:=(i1+i2) div 2+1;
  if a[i]<x then i2:=(i1+i2) div 2-1;
 until (a[i]=x)or(i1>i2);
 if a[i]=x then 
  begin
  writeln('Искомый(ые) номер(а) элемента(ов):');
  while (i>0)and(a[i]=x) do i:=i-1;
  i:=i+1;
  while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end;
  end
  else writeln('Элемент не найден');
 writeln;
end.

Пример:
Исходный массив:
15 4 16 3 7 10 3 1 18 6 18 2 7 11 10 16 2 10 7 12 
Отсортированный массив:
18 18 16 16 15 12 11 10 10 10 7 7 7 6 4 3 3 2 2 1 
x = 10
Искомый(ые) номер(а) элемента(ов):
8 9 10 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?