Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Булат228337
21.02.2021 00:01 •
Информатика
1.дан прямоугольный треугольник с катетами а и б составьте программу для вычисления гипотенузы с 2. даны длины сторон треугольника. составьте программу для вычисления его площади.
Ответ:
Parade93
06.10.2020 01:46
№1. Вычисление гипотенузы прямоугольного треугольника по двум катетам:
program znanija
var
a,b: real;
c: real;
begin
write ('Введите длины катетов.');
readln (a,b);
c:=sqrt(a*a+b*b);
writeln ('Гипотенуза треугольника равна:', c);
end.
№2. Вычисление площади треугольника по длинам сторон:
program znanija
var
a, b, c, p, s : real;
begin
write ('Введите длины сторон.');
read (a, b, c);
p:=(a + b + c)/2;
s:=sqrt(p*(p - a)*(p - b)*(p - c));
writeln ('Площадь треугольника равна:', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
кира650
08.12.2021 22:43
Даны 4 целых числа ,записанные в двоичной системе: 11000000,11000011,11011001,11011111.запишите их в порядке убывания. желательно сфотографировать....
Soffik0611
08.12.2021 22:43
Врач-стоматолог принимает пациентов с 8 утра до 2 часов дня. на каж¬дого пациента отводится по 30 минут. какое количество информации со¬держит сообщение о том, что петя записался...
sladkoe102
08.12.2021 22:43
Pascal авс - написать программу, ! для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · если все числа не превышают 30, то выведите...
Barsik12847
15.02.2022 11:41
Алёша, Боря и Гриша нашли в земле старинный сосуд. Рассматривая удивительную находку, каждый высказал по два предположения: 1) Алёша: «Это сосуд греческий и изготовлен в V веке»....
natali2613
13.09.2022 21:24
Задача 2. Получить таблицу значений функции y=x2 для x= от 20 до 1 с шагом 2 МОЖЕТЕ НАПИСАТЬ В ПРОГРАММЕ PYTHON ...
Moonlight06
01.10.2022 12:52
Каким образом можно записать функцию вычисляющую остаток от деления в c++. например, нужно найти остаток от деления 100 на 7...
StalinReal
05.08.2021 09:43
Вкажіть засіб поетичного вираження в рядках: Вже червоніють помідори, І ходить осінь по траві (М. Рильський). варіанти відповідей оксиморон порівняння персоніфікація алегорія...
dkfdshjdgss
26.03.2020 01:50
Помилку в утворенні форми ступеня порівняння прислівника допущено в рядку...
Vafelka225
14.01.2023 17:33
Побудувати зображення предмета у розсіювальній лінзі, якщо предмет знаходиться над фокусом (d=F). Яке це зображення?...
Golovina077
19.09.2021 18:43
Напишите уравнения реакций согласно цепочке превращений: S → SO2 → Na2SO3 → Na2SO4 → NaBr → NaNO3 → O2....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program znanija
var
a,b: real;
c: real;
begin
write ('Введите длины катетов.');
readln (a,b);
c:=sqrt(a*a+b*b);
writeln ('Гипотенуза треугольника равна:', c);
end.
№2. Вычисление площади треугольника по длинам сторон:
program znanija
var
a, b, c, p, s : real;
begin
write ('Введите длины сторон.');
read (a, b, c);
p:=(a + b + c)/2;
s:=sqrt(p*(p - a)*(p - b)*(p - c));
writeln ('Площадь треугольника равна:', s);
end.