В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
викусик152
викусик152
15.11.2020 21:41 •  Информатика

Напишите программу на языке си. придумайте алгоритм, вводящий три целых числа, который находит второе по величине число, если оно существует

Ответ:
LyusiaG
LyusiaG
06.10.2020 01:45
На C++. Если среднее число равно меньшему или максимальному, то выводит No (вариант с "невозможно определить").

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
 #pragma waring(disable:4996);
 
 int a,b,c,d;
 scanf("%d%d%d",&a,&b,&c);
 if(max(a,b) != min(a,b)){
   d = max(a,b);
 }else{
   printf("NO");return 0;
}
if(d > c && c!= min(a,b)){
 printf("%d",c);return 0;
}
if( d < c){
  printf("%d",d); return 0;

printf("NO");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?