В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hvorovmax
hvorovmax
29.07.2020 12:53 •  Информатика

Pascalabc нужно написать программу с "if" вот сама : даны два угла теугольника (в градусах) (которые вводит пользователь). определить, существует ли такой треугольник. если да, то будет ли он прямоугольным?

Ответ:
valeroon16
valeroon16
20.08.2020 17:22
Var
    a, b: integer;

begin
    readln(a, b);
    if a + b >= 180 then
        writeln('Такой треугольник не может существовать')
    else if (a = 90) or (b = 90) or (a + b = 90) then
        writeln('Это прямоугольный треугольник')
    else
        writeln('Это треугольник')
end.

если надо записать в стиле PascalABC.Net, скажи допишу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?