В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aidaadilbekova
aidaadilbekova
29.07.2020 12:53 •  Информатика

Нужно, составьте программу на языке паскаль для нахождения радиуса описанной окружности вокруг треугольника, если известны стороны треугольника.

Ответ:
Dameni04
Dameni04
06.10.2020 00:49
Var
   a,b,c,p:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if (a<b+c)and(b<c+a)and(c<a+b) then
   Begin
   p:=(a+b+c)/2;
   WriteLn('R = ',a*b*c/Sqrt(p*(p-a)*(p-b)*(p-c)));
   End
else WriteLn('Треугольник не существует')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?