В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
миня
миня
08.05.2021 05:42 •  Информатика

Написать программу решения уравнения ax(в 3 степени ) + bx=0 для произвольных а, в, значения которых вводятся с клавиатуры

Ответ:
arrrrrrrrr1
arrrrrrrrr1
03.08.2020 10:15
ax^3+bx=0
x(ax^2+b)=0
Получим несколько решений:
1.)x=0
2.)ax^2+b=0
ax^2=-b
x^2=- \frac{b}{a}
x_{1} = \sqrt{- \frac{b}{a}}
x_{2} = -\sqrt{- \frac{b}{a}}

var
  a, b: real;

begin
  readln(a, b);
  writeln('x = 0');
  if (-b/a) >= 0 then
  begin
    writeln('x = ', sqrt(-b/a));
    writeln('x = ', -sqrt(-b/a));
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?