В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sonya1233210
Sonya1233210
10.09.2020 03:22 •  Информатика

Дан массив из 30 произвольных элементов, каждый из которых не больше 100. найдите максимальный элемент кратный 9.

Ответ:
Natalivizer
Natalivizer
05.10.2020 22:52
Const
   N = 30;
Var
   A:array[1..N] of byte;
   i,Max:integer;
Begin
Max:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(101);
    if (A[i] mod 9 = 0)and(A[i] > Max) then Max:=A[i];
    Write(A[i],' ');
    End;
WriteLn;
if Max = 0 then WriteLn('В массиве нет элементов, кратных 9')
else WriteLn('Max = ',Max)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?