В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gamerXpro
gamerXpro
16.09.2021 00:40 •  Информатика

20.2 напишите программу, которая в последовательности натуральных чисел определяет максимальное из четных чисел, содержащих на втором месте справа цифру 7. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести максимальное из четных чисел, содержащих на втором месте справа цифру 7 пример работы программы: входные данные выходные данные 1074 2473 1586 2272 76 0 2272

Ответ:
13895702084657812570
13895702084657812570
05.10.2020 22:47
#Python 3.5.2
a, mx = 1, -1
while a!=0:
    a = int(input())
    if (a%2==0) and (a//10%10==7) and (a>mx): mx=a;
print (mx)

//FPC 2.6.4
var
a, max: integer;
begin
max:=-1;
repeat
readln (a);
 if (a mod 2=0) and (a div 10 mod 10=7) and (a>max) then max:=a;
until a=0;
write (max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?