В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kov3456
Kov3456
02.04.2020 12:16 •  Информатика

♥♥♥♥ дан массив из 20 произвольных элементов, каждый из которых не больше 100. найдите максимальный элемент кратный 6.

Ответ:
Snzjxj
Snzjxj
26.08.2020 10:56
Const k=6;
var a:array [1..20] of integer;
i,max:integer;
Begin
max:=-1;
for i:=1 to 20 do begin
a[i]:=random(100); (или for i:=1 to 20 do writeln(a[i]); - здесь ручной ввод)
if a[i] mod k = 0 then begin
if a[i]>max then max:=a[i]; end;
end;
writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?