В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sashabiryukova
sashabiryukova
14.06.2021 09:55 •  Информатика

Составить программу, которая заполняет массив из 20 элементов с генератора случайных чисел. требуется вывести элементы массива на экран компьютера в одну строку, а затем определить сумму элементов массива и среднее арифметическое массива.

Ответ:
marisha168
marisha168
05.10.2020 22:43
Program n1;
var a: array[1..20] of integer;
i,sum: integer;
begin
randomize;
write('исходный массив: ');
sum:=0;
for i:=1 to 20 do
begin
a[i]:=random(21);
write(a[i],' ');
sum:=sum+a[i];
end;
writeln;
writeln('сумма: ',sum);
writeln('срзнач: ',sum/20);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?