В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
хамзикош
хамзикош
25.10.2020 09:42 •  Информатика

Напишите программу в pascal abc для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.

Ответ:
Sofwork
Sofwork
05.10.2020 22:41
Var
   n,S,S3:integer;
Begin
Write('n = ');
ReadLn(n);
For n:= 1 to n do
    Begin
    S:=S+n;
    if n mod 3 = 0 then S3:=S3+n;
    End;
WriteLn('Сумма чисел [1..',n,'], кратных трём: ',S3);
WriteLn('Сумма всех чисел [1..',n,']: ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?