В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
58310
58310
16.05.2020 00:10 •  Информатика

Напишите программу(паскаль) нахождения суммы элементов массива а[1..15], кратных 5 и меньших 50. массив заполняется произвольными числами в диапазоне да 100

Ответ:
liliaadderson
liliaadderson
05.10.2020 22:31
Const N = 15;
Var
   A:array[1..N] of integer;
   i:integer;
   S:real;
Begin
S:=0;
Write('Исходный массив: ');
For i:= 1 to N do
    Begin
    A[i]:=random(100);
    Write(A[i],' ');
    if (A[i]<50)and(A[i] mod 5 = 0) then S:=S+A[i];
    End;
WriteLn;
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?