В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kiakev
kiakev
31.03.2021 17:16 •  Информатика

Составить программу, печатающую все простые числа, не превосходящие данного числа. большое.

Ответ:
FEDY200599999M
FEDY200599999M
31.08.2020 22:24
Uses crt;
var k,i,n,s:integer;
istin:boolean;
label 1,2;
begin clrscr;
 k:=1;
writeln ('vvedite chislo');
readln(n);
1:n:=n;
for s:=2 to n-1 do begin if n mod s=0 then begin n:=n+1;
goto 1;
end else goto 2;
end;
2:while k<100 do begin istin:=true;
i:=3;
while (i<=trunc(sqrt(n))) and istin do if n mod i=0 then istin:=false else i:=i+2;
if istin then begin write(n,' ');
k:=k+1;
end;
 n:=n+2;
end;
readkey
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?