Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
цццрпппр1
14.11.2021 07:20 •
Информатика
Написать на языке паскаль программу ввода четырех целых чисел и вычисления их среднего арифметического.
Ответ:
кэтси
14.08.2020 21:23
1 вариант:
Var A,S:integer;
Begin
S:=0;
Write('A = ');ReadLn(A);
S:=S+A;
Write('B = ');ReadLn(A);
S:=S+A;
Write('C = ');ReadLn(A);
S:=S+A;
Write('D = ');ReadLn(A);
S:=S+A;
WriteLn('Sr = ',S/4)
End.
Второй вариант:
Var
A,B,C,D:integer;
Begin
WriteLn('Введите 4 целых числа');
ReadLn(A,B,C,D);
WriteLn('Sr = ',(A+B+C+D)/4)
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
enotic009
09.01.2021 23:44
1. (0.5б)Публікація — це... А) процес і результат оприлюднення повідомлень, видання; Б) галузь промисловості, що займається виготовленням друкованої продукції; B)...
Gowaimargowa123
13.04.2020 04:25
Размер документа 11 байт а на диске 4 кб почему...
ева19961
13.04.2020 04:25
Составьте программу, которая заполняет массив случайными целыми числами в диапазоне от 0 до 2 и выводит на экран количество элементов, равных 1...
ДарьяРэя
13.04.2020 04:25
Составить блок-схему алгоритма вычисления значения функции y =a2 + x для -15 x 15, 0 a 10 с шагом равным 1...
ТахминаЖамалдинова
13.04.2020 04:25
Pascal из заданного текста предложения выбрать и напечатать только те символы, которые встречаются в нем только один раз (в том порядке, в котором они встречаются...
aiskfjdUe
25.03.2021 00:43
1)что такое код? примеры 2)что такое кодирование примеры 3)от чего зависли кодирования иноформации? 4)какие кодирования применяют чате всего? 5)что такое декодирование?...
annetalovecamar
22.11.2020 00:42
Запишите в виде несократимой дроби...
аличка77
22.11.2020 00:42
(Прочитайте така и напишите по The Little watI got a little cal for my birthday. My brother put her in a small box. I opened the box and smiled. I saw alittle brown...
Demians
22.11.2020 00:42
Как какать? Стоя или сидя? ...
venerkaasanova
22.11.2020 00:42
Прочитайте текст і виконайте завдання 1 ─ 4. [1] На ще не зовсім заплющене око озера впав густий туман. [2] Улоговину заповнив білий пухнастий оболок, що спустився...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var A,S:integer;
Begin
S:=0;
Write('A = ');ReadLn(A);
S:=S+A;
Write('B = ');ReadLn(A);
S:=S+A;
Write('C = ');ReadLn(A);
S:=S+A;
Write('D = ');ReadLn(A);
S:=S+A;
WriteLn('Sr = ',S/4)
End.
Второй вариант:
Var
A,B,C,D:integer;
Begin
WriteLn('Введите 4 целых числа');
ReadLn(A,B,C,D);
WriteLn('Sr = ',(A+B+C+D)/4)
End.