В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
birdibir
birdibir
22.06.2020 23:39 •  Информатика

Надо решить двумерным массивом! даны два числа n и m. создайте двумерный массив [n][m] и заполните его по следующим правилам: числа, стоящие в строке 0 или в столбце 0 равны 1 (a[0][j]=1, a[i][0]=1). для всех остальных элементов массива a[i][j]=a[i-1][j]+a[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. входные данные программа получает на вход два числа n и m. выходные данные выведите данный массив. примеры входные данные 3 3 выходные данные 1 1 1 1 2 3 1 3 6

Ответ:
mirtovamasha
mirtovamasha
03.08.2020 09:17
Const
   N = 3;
   M = 4;
Var
   A:array[0..N-1,0..M-1] of integer;
   i,j,k:integer;
Begin
For i:= 0 to N-1 do
    For j:= 0 to M-1 do
        if i*j = 0 then A[i,j]:=1;
if M>N then k:=M
else k:=N;
For k:= 1 to k-1 do
    For i:= 1 to N-1 do
        For j:= 1 to M-1 do
            if (i = k)or(j = k) then
               A[i,j]:=A[i-1,j]+A[i,j-1];
For i:= 0 to N-1 do
    For j:= 0 to M-1 do
        Write(A[i,j],' ');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?