В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aynuran1
aynuran1
19.11.2021 18:04 •  Информатика

Составить программу заполняя масива из 100 чисел случаиними значениями -20 до 20 . почитать количество отрецательних и положительних чисел .

Ответ:
АннаМарияЛуиза
АннаМарияЛуиза
14.08.2020 20:50
Var A:array[1..100] of integer;
i,Ko,Kp:integer;
Begin
Ko:=0;
Kp:=0;
Write('Исходный массив: ');
For i:= 1 to 100 do
    Begin
    A[i]:=random(41)-20;
    Write(A[i],' ');
    if A[i]<0 then Ko:=Ko+1
    else if A[i]>0 then Kp:=Kp+1;
    End;
WriteLn;
WriteLn('Количество отрицательных: ',Ko);
WriteLn('Количество положительных: ',Kp);
End.
0,0(0 оценок)
Ответ:
animetan200
animetan200
14.08.2020 20:50
Var
  arr : array [1.. 100] of integer;
  i, sum1, sum2 : byte;
 
begin
Randomize();
for i := 1 to 100 do
  begin
  arr[i] := random(-20, 20);
  if arr[i] < 0 then
  sum1 += 1
  else if arr[i] > 0 then
  sum2 += 1
  end;writeln('Количсетво отрицательных чисел: ', sum1);
writeln('Количество положительных чисел: ', sum2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?