В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Gromova3232
Gromova3232
29.06.2020 21:47 •  Информатика

Pascal abc. написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case).

Ответ:
диана2460
диана2460
14.08.2020 20:49
Var n,d:integer;
begin
write('Введите месяц :');
readln(n);
write('Введите день :');
readln(d);
n:=n mod 12;

 case n mod 12 of
 1: if d<=20 then writeln('Козерок') else writeln('Водолей');
 2: if d<=21 then writeln('Водолей') else writeln('рыба');
 3: if d<=21 then writeln('рыба')   else writeln('овен');
 4: if d<=21 then writeln('овен')   else writeln('телец');
 5: if d<=21 then writeln('телец')   else writeln('близницы');
 6: if d<=22 then writeln('близницы')   else writeln('рак');
 7: if d<=23 then writeln('рак')   else writeln('лев');
 8: if d<=24 then writeln('лев')   else writeln('дева');
 9: if d<=24 then writeln('дева')   else writeln('весы');
 10: if d<=24 then writeln('весы')   else writeln('скорпион');
 11: if d<=23 then writeln('скорпион')   else writeln('стрелец');
 12: if d<=22 then writeln('стрелец')   else writeln('козерок');
end;
end.

//без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?