В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
diana1157
diana1157
28.08.2020 08:39 •  Информатика

)на языке pascal составить программу, которая находит номер первого встречающегося в массиве числа 7.

Ответ:
a1400434
a1400434
05.10.2020 21:50
Var f:text; a:array[1..7] of real; i,k,c,x:integer; s:string;
begin
 for i:=1 to 7 do
   begin
    readln(x);
    a[i]:=x;
   end;
 assign(f,'file.txt');
 rewrite(f);
 for i:=1 to 7 do
   begin
    str(a[i],s);
    writeln(f,s);
   end;
 close(f);
 reset(f);
 k:=0;
 while not eof(f) do
   begin
    readln(f,s);
    val(s,x,c);
    if x<0 then k:=k+1;
   end;
 close(f);
 if k<>0 then writeln('В массиве ',k,' отрицательных элемента(ов)');
  else writeln('В массиве нет отрицательных элементов');
 erase(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?