В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
chvitalie24
chvitalie24
14.01.2020 12:15 •  Информатика

1) составьте программу вычисления произведения чисел от 1 до 10 (1*2*3*..*) 2)составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10 3)составьте программу, которая находит сумму квадратов чисел от 1 до 10

Ответ:
danyabro1
danyabro1
14.08.2020 20:46
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=Range(1,10);
  Writeln(s.Aggregate(1,(p,q)->p*q));
  Writeln('S=',s.Where(k->k.IsEven).Sum,', П=',
      s.Where(k->k.IsOdd).Aggregate(1,(p,q)->p*q));
  Writeln('S2=',s.Select(k->k*k).Sum)
end.

Результат
3628800
S=30, П=945
S2=385
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?