В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
олеся786
олеся786
11.08.2020 05:57 •  Информатика

Дан массив из 10 чисел. определите,сколько элементов массива имеют минимальное значение.(напишите программу)

Ответ:
sbordog1337bogdan
sbordog1337bogdan
05.10.2020 21:24
Var
m: array [1..10] of integer;
max, k, i: integer;
begin
for i := 1 to 10 do
read(m[i]);

max := m[1];
k := 1;

for i := 2 to 10 do
if m[i] > max then
begin
k := 1;
max := m[i]
end
else
if m[i] = max then
inc(k);
write(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?