В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
liteman1000ow7ldr
liteman1000ow7ldr
04.01.2020 23:56 •  Информатика

Напишите программу, которая выводит все простые числа в диапазоне от 2 до n ( n заранее неизвестно). входные данные входная строка содержит целое число n . выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные 20 выходные данные 2 3 5 7 11 13 17 19

Ответ:
адэли12
адэли12
26.08.2020 10:21
Var
A,N,d:integer;
Begin
Write('N = ');ReadLn(N);
For N:= 2 to N do
    Begin
    d:=0;
    A:=2;
    Repeat
    if N mod A = 0 then d:=d+1;
    A:=A+1
    Until A>Sqrt(N)+1;
    if d = 0 then Write(N,' ')
    End
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?