В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
546546YGygY
546546YGygY
07.04.2023 02:27 •  Информатика

Написать программу, которая выводит на экран из введенной пользователем строки слово с заданным пользователем номером c++ ,

Ответ:
ekaterinaf79
ekaterinaf79
05.10.2020 20:48
#include <bits/stdc++.h>
using namespace std;
int main(){    string s; getline(cin, s);    int n; cin >> n;    int cur = 1, i;    for(i = 0 ; i < s.size() ; i ++)    {        if(s[i] == ' ')            cur++;        if(cur >= n)            break;    }    string ans = "";    if(n != 1)        ++i;    while(s[i] != ' ' && i < s.size())    {        ans += s[i];        ++i;    }    cout << ans << "\n";}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?