В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ribka0703
ribka0703
06.12.2021 18:10 •  Информатика

Вопрос по информатике. написать программу на языке freepascal. дан массив определённой длины, в котором могут быть как положительные, так и отрицательные числа. проинициализировать массив и найти кол-во элементов массива до первого отрицательного и сумму элементов после него

Ответ:
стас2118
стас2118
05.10.2020 20:47
Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
   S:real;
Begin
Randomize;
ClrScr;
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')
    End;
WriteLn;
i:=1;
k:=0;
While (A[i]>=0)and(i<N) do
   Begin
   k:=k+1;
   i:=i+1
   End;
if A[i]>=0 then k:=k+1;
WriteLn('k = ',k);
S:=0;
For i:= i+1 to N do
    S:=S+A[i];
WriteLn('S = ',S:0:3);
ReadLn
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?