В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kamila267
kamila267
21.05.2023 06:57 •  Информатика

Плз! на языке паскаля составьте программу, которая по введенному вами k – числу грибов, печатает фразу «мы нашли в лесу k грибов, причем согласовывает окончание слова «гриб» с числом k.

Ответ:
ХорошийВася
ХорошийВася
05.10.2020 20:47
Var
k:integer;
Begin
Write('k = ');ReadLn(k);
Write('Мы нашли ',k);
if (k>9)and(k<20) then WriteLn(' грибов')
else
   Case k mod 10 of
   0,5..9:WriteLn(' грибов');
   1:WriteLn(' гриб');
   2..4:WriteLn(' гриба');
   End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?