В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SOSplizz
SOSplizz
06.03.2021 23:38 •  Информатика

5. составьте программу сортировки по возрастанию значений в трех переменных: а, в, с. 6. составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов. не из

Ответ:
JULIA110
JULIA110
09.08.2020 19:41
Var
A,B,C:integer;
Begin

WriteLn('Введите три числа');
ReadLn(A,B,C);
if (A<=B)and(B<=C) then Write(A,' ',B,' ',C)
else if (A<=C)and(C<=B) then Write(A,' ',C,' ',B)
else if (B<=A)and(A<=C) then Write(B,' ',A,' ',C)
else if (B<=C)and(C<=A) then Write(B,' ',C,' ',A)
else if (C<=A)and(A<=B) then Write(C,' ',A,' ',B)
else if (C<=B)and(B<=A) then Write(C,' ',B,' ',A)
End.

Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
   Begin
   WriteLn('x = ',(-b-sqrt(D))/(2*a));
   WriteLn('x = ',(-b+sqrt(D))/(2*a));
   End
else WriteLn('Действительных корней нет')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?