В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
пупсикг
пупсикг
29.09.2022 01:16 •  Информатика

Написать программу в free pascal'e,! условие: пусть k - целое от 1 до 365. присвоить целой переменной n значение 1, 2, 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.

Ответ:
abdullaxadeaygün
abdullaxadeaygün
05.10.2020 20:07
Var k,n:integer;
begin
write('k = ');
readln(k);
n:=(k-1) mod 7+1;
writeln('n = ',n);
end.

Пример:
k = 21
n = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?