В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladarzm
vladarzm
28.10.2020 08:54 •  Информатика

Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. используйте процедуру. входные данные входная строка содержит неотрицательное число n . выходные данные программа должна вывести в столбик все цифры введённого числа, начиная с первой. примеры входные данные 1234 выходные данные 1 2 3 4 на паскале.

Ответ:
Kondor1337
Kondor1337
05.10.2020 19:56
Без рекурсии:

Procedure ABC(N:integer);
Var
C:integer;
Begin
C:=0;
While N>0 do
   Begin
   C:=C*10+N mod 10;
   N:=N div 10
   End;
While C>0 do
   Begin
   WriteLn(C mod 10);
   C:=C div 10
   End
End;

Var
N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.

С рекурсией:

Procedure ABC(N:integer);
Begin
if N>0 then
   Begin
   ABC(N div 10);
   WriteLn(N mod 10);
   End
End;
Var N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?